CTDP 2006 1.1 FAQ

This is still work in progress, but it contains a list of things I have seen i.e. frequently asked on various forums.  so here  is a  FAQ that may accompany the manual.   I will update it  in the next few days but here is a transcript of what I got so far.  Any additions you would like to see let me know.

Q. I see no car models and get loading errors after installing the mod

A. More than likely you installed the server version, uninstall it, download the full version
and reinstall.

Q. I cannot change the rev  limit of the cars in the car setup screen and the engine revs are  greyed out

A. Engine rpms are controlled entirely with the boost buttons,  and effectively allows the engine revs to be set in the car while driving, boost 1, maximum revs, boost 9 minimum revs.

Q. My frame rates are very poor, what can I do

A. When racing with full grids it is recommended to set the LOD slider in the CTDP control Center to a lower setting, especially if your ingame settings are at maximum, this applies to high end systems too, reducing visible vehicles and shadows can make a large difference.  Unless you got the latest cards like Ati 4870×2 in crossfire or Nvidia gtx280 in SLI it is still recommended setting at the LOD slider to the second highest setting at minimum.   The highest setting can be used for test day or when a limited number of vehicles are on track, or for watching replays and making movie files from you replays for high fidelity results.  If you do not reduce this slider from maximum, the mod will use large amounts of memory that will push close to the 32 bit limit with large number of drivers  (> 25 or so) .  In practice most 32 bit operating systems cap at around 3.2 Gb even when 4Gb is intalled ( for various reasons) !

Ultimately this is a high detail mod, and detail comes at a price. To get the best result a PC with CPU core 2 duo 2.2 Ghz (or AMD equivalent) or above with 2 – 4 Gb DDR2 memory, a 256 bit 512 Mb Video card is recommended for a full 22 car grid in order to  maintain reasonably good visual quality with acceptable framerates. For sure  the mod will run on lesser systems, but consider reducing both ingame settings  as well as setting the control center LOD slider to one of the lowest settings and use the autoFPS feature, in this way rFactor wil attempt to minimise framerate dips below a specified value.

Q. The AI don’t work or are very slow.

A. This is a track related issue and has been reported on some tracks. unless you know how to edit mods or happy to play offline only where mismatches are not an issue there is no quick fix at this time.

Q. What’s going on with the upgrades, on some tracks the engines can rev higher or lower than others, different tyre choices and things seem to change randomly from track to track.

A. For tracks that were on the FIA 2006 calender that are suported by the mod, each Team has forced upgrades and air pressures,  you can try changing them in the “buy upgrades” tab in the user interface, but it wont have any effect once you go out on track if the upgrades is either Track conditions or Track Configuration these are forced  in any case.  Other upgrades such as the shift light and mirrors upgrades are optional. 

Tracks that are not listed on the FIA 2006 Calender have forced post season physics that is effectively the same as the Brazil version of the cars on a standard air pressure day, this cannot be changed unless you edit the mod which will cause mismatches.

You cannot change any upgrades between qualifying and race, this is particularly important when picking the shift light upgrade, although in version 1.1  a suitable default HUD shiftlight level is now set,  should you change it, always decide your upgrade before loading the track and set it for race !  The shift light upgrade does not change the LED shift lights on the steering wheel in any way,  it is for the HUD only and may also be useful for players using the autoshift driving aid .
 

Q. The offline AI cars should have the correct liveries for each track but it is not working

A. Not all tracks are supported, in some cases tracks don’t support this feature well, depending on track folder structure, especially if more than one version of a track is installed and contained in the same subfolder. This is an rfactor track issue. Note that tracks that were not on the  FIA 2006 calender will use a default livery.

Q. when I buy a car and go out on track the incorrect livery for that round is loaded.

A. Human drivers must still pick their livery from the user interface,
the automatic loading of liveries applies to AI opponents only.

Q. Cars fail to load in the showroom or rfactor crashes in the user interface or soon while loading a track

A. The most common reason is an incorrect or a corrupt installation, or the first item in this FAQ will also cause this, however it will also be caused by a setting for the user interface, make sure that you have always set  UI detail to low.  This setting is contained in the user profile PLR file. Open it with notepad and it as follows,

Low Detail UI=”1″

This file may be found in \UserData\playername\playername.PLR

This has no effect on the display quality of the cars in the showroom or on track.

Q. The mod is huge in size and the liveries occupy a large amount of disk space,
will reducing the texture from 2048×2048  down to 1024×1024 and resaving them improve peformance ?

A. Read the manual for more information, contrary to what you may think, the answer is no. You can force texture sizes loaded in by rfactor already due to the DDS mipmap feature, to use a smaller texture size you specify it in the user profile, or change ingame settings, in which case the texture size is determined from the detail setting, but this can also be done independently from model (LOD) detail if desired with some edit tweaks in your user profile .  

There is no need to resave hundreds of textures in the skins folders, unless you want to save diskspace.

Q. On some tracks the car livery looks corrupt or wrong.


A. In some cases it may occur that a track and mod have conflicting textures, mosty due to sloppy and lazy naming conventions, however we have tried to reduce this in patch 1.1 by avoiding common texture names, but there is no guarentee that some tracks somewhere will cause such issues.

Q. Why do my replays crash

A. while we have attempted a fix in patch 1.1 relating to music files which worked as far as we know,  should it still occur try removing the music mp3 files from the music folder in the first instance to see if it resolves the issue.  The music files are located  in Music\CTDP2006.  In some cases it may also be caused by a corrupt replay file.

Q.  Do I have to launch the mod from the CTDP control center ?

A. No. If you use the CTDP control center to change settings and launch rfactor directly from its own shortcut it will still use those settings and work . In fact should you have any issues or crashes you may like to try this as an alternative to see if it resolves it. The launch rfactor option in the control center is there for convenience and a way to easily add other startup options to rfactor.

Q.  The steering wheel rev lights since patch 1.1 no longer light up all the way to red, sometimes only green or yellow, why ?

A. This is deliberate, the rev light wil only come on fully on the max available revs on max boost 1, just like reality, the rev lights on steering wheels rarely come on in race conditions. Typically on boost 6, the recommended race setting, green and yellow rev lights will come on before the limiter,  letting the driver know that the engine is in the “save” zone.

Q.  The cars that have a rev lights on the dashboard  like Mclaren do not work in TV cam view but only in cockpit view

A. This is not a bug, but an rfactor limitation, there is no fix, although there is a kind of fudge workaround by making the cockpit view the TVcam view if you know how.

Q. When starting a championship sometimes the wrong track loads or rFactor may crash to desktop

If the track is not installed this may happen.  Tracks will not work unless they are exactly named to match the names in the championship list, so while one version of australia will work another may not. We have tried however to use mostly commonly available tracks that are downloadable from http://www.rfactorcentral.com and http://www.nogripracing.com . You may use championship manager to customise a championship, but as such, due to track AI inconstistencies, and the fact this mod does not come with a trackpack, championship mode is not supported and untested.  Better result are achieved by running each round separately, find an AI strength setting  for each track, typically 95 – 100% gives realistic AI laptimes, running it that way is the best solution. The rFactor AI track learning feature will also help to stabilise AI.

Q. When I go out onto track with multiple AI cars, all the opponent cars are the same as the team I am driving.

A. Before track loading under opponents ensure you select CTDPF1_2006 to get all Teams out on track.  By default when a vehicle is selected, only the vehicle filter of your own team is selected as possible AI opponent.

Q. When racing tracks in some cars autoshifting fails to work, why ?

A. This is a bug that has come to light in version 1.1. Brief test shown that it affects Ferrari on non 2006 tracks, Pick a shiftlight upgrade that is lower than the max rev available for now and it will work.   The default setting for the shiftlight upgrade appears to be incorrect for some cars, but it does not affect all cars. At this time it is not known which Teams/cars are affected by this. Tests have shown Midland/Spyker is correct, Ferrari is not.

Q. Which tracks work with the mod ?

While we haven’t tested them, All tracks work, in theory, the only differene will be what upgrades are imposed as  explained in the question relating to upgrades.  Some track/cars may have AI issues, given the autoshift issue in 1.1 as stated in the previous item. Also some tracks the AI may not work due to issues with the track itself.   See this thread for further information http://devblog.ctdp.net/?p=526 . Some common tracks that are known to work with the upgrades are (amongst others):

CTDP Bahrain  http://rfactorcentral.com/detail.cfm?ID=Bahrain%20International 

Sepang GP4 http://rfactorcentral.com/detail.cfm?ID=Sepang%20GP4 

Albert Pack-GP4 http://rfactorcentral.com/detail.cfm?ID=Albert%20Park%20GP4 

2006 Imola GP http://rfactorcentral.com/detail.cfm?ID=2006%20Imola%20GP 

Nuerburg http://rfactorcentral.com/detail.cfm?ID=Nuerburg 

Barcelona http://rfactorcentral.com/detail.cfm?ID=Barcelona 

Monaco http://rfactorcentral.com/detail.cfm?ID=Monaco%20New%20Layout  http://rfactorcentral.com/detail.cfm?ID=Monaco%20EMG 

Northamptonshire http://rfactorcentral.com/detail.cfm?ID=Northamptonshire 

Montreal http://rfactorcentral.com/detail.cfm?ID=Montreal%20ISI,

Indianapolis  http://rfactorcentral.com/detail.cfm?ID=Indianapolis%20GP4 

Magny Cours  http://rfactorcentral.com/detail.cfm?ID=Magny%2DCours%20GP4, http://www.nogripracing.com/details.php?filenr=907  

Hockenheim http://www.nogripracing.com/details.php?filenr=1004 

Hungary http://rfactorcentral.com/detail.cfm?ID=Hungaroring%20EMG 

Brianza (Monza)   http://rfactorcentral.com/detail.cfm?ID=Brianza 

China http://rfactorcentral.com/detail.cfm?ID=Jiading http://rfactorcentral.com/detail.cfm?ID=Shanghai 

Japan/Suzuka  http://rfactorcentral.com/detail.cfm?ID=Suzuka%20GP4 http://rfactorcentral.com/detail.cfm?ID=Suzuka%20EOAA 

Interlagos  http://rfactorcentral.com/detail.cfm?ID=Interlagos%20EOAA http://rfactorcentral.com/detail.cfm?ID=Interlagos%20GP4 

This is by no means the entire a list but something to get you started.

Q. A mismatch is reported when joining a dedicated server, why?

A. Due to  a collision geometry error a mismatch will be reported when the LOD slider setting in the control center graphicsettings tab is set to medium High.  Three ticks from the left or exactly set in the middle . Use either a lower or higher setting will resolve this.

Q. I am missing car sounds for the safety car

A. When using an rF lite installation the safety car has no sound due to missing sound files.  Copy the sound folder  GameData\Vehicles\Sounds\50V8FPEngine from a full rfactor installation to your CTDP installation will solve this.

Q. Where are the moving arms.

A. They are on their way in the next 2 – 3 days 😉

Published by

(CTDP)afborro

CTDP member

48 thoughts on “CTDP 2006 1.1 FAQ”

  1. Very good.
    When I first tried the mod, this afternoon, I thought that disappearing lights on the steering wheel were a bug, but than I changed boost and saw that they came back: good feature!

  2. @CTDP management,
    I have a weird problem! I reinstalled rFactor with CTDP v1.1 (full .exe 1.35Gb)! When I join a server I got a mismatch “FER_F248.HDV or Track Config” mismatch??? I reinstalled the track and tried other cars but no way??? I even created a new profile but it still didn’t solve the problem???
    Can anybody help me?
    Thanks in advance 😉
    Oli

  3. We made the stupid mistake of not adding the mod versionnumber to the Modname, so both version 1.0 and 1.1 are displayed by the same name and can not be distiguished. Sorry, we missed that one, wait a few days, till the servers switch to the new version.

  4. Ok Dahie but it has nothing to do with a display problem! I’m in a league where they patched the server to the v1.1. I did the same like mentionned in my previous post but when I enter the room I’ve got that mismatch and I can’t solve it! What could it be! I’m pretty sure I did nothing wrong during the installation since I simply reinstalled rFactor followed by your full installer v1.1!
    Can you help me?
    Thank you again,
    Oli

  5. Now I read the auto shift problem is a bug and not my retarded mind. Too bad I already killed myself. “A mind is a terrible thing to have had”

  6. With max RPM now on boost 1, when I use temp boost as a “push to pass” (as honda & maybe others did in 06)I now get minimum RPM rather than maximum. Any fix for this?

  7. @Klutch,
    To solve the problem I simply reinstalled rFactor. Then I installed CTDP2006 v1.0 (not 1.1) and finally the patch v1.1! Now it’s working! Very strange and nothing to do with LOD level!

  8. @maranello55,
    To solve the problem I simply reinstalled rFactor. Then I installed CTDP2006 v1.0 (not 1.1) and finally the patch v1.1! Now it’s working! Very strange and nothing to do with LOD level!

  9. @Prenthouse.

    For sure there is a bug in the lod level slider as stated in the FAQ with a fresh new install of 1.1.

    Try putting the LOD slider bang in the middle in the CTDP control center, join a server 1.1, you should get a mismatch, let me know otherwise. My guess the fulll install will have reset this slider for you to default where the issue does not occur, whereas the patch may not do that if you had it previously set in the middle, it would proably leave it there.

    If what you say is right it means we potentially have different files in our patch compared with full installation, which I highly doubt.

    It would be better to contact us in the forum or mail if you think what you say is true rather than providing potentially incorrect information that may be misleading to others,

    Wihout trying to be harsh, but others may waste time doing things in the way you say for no goood reason.

    @Klutch, As for the moving arsm they are with beta testers but over Easter weekend, I doubt much progres will be made getting the installer ready until next week. Sorry, we just want to eliminate and keep an eye on issues and releasing the addon without installer could complicate matters for us.

  10. @Prenthouse

    My main server was installed using the full version 1.1. Even with the LOD slider adjusted, they cant go in without a mismatch. Then Ive installed using the full version 1.1, and able to join in with no mismatch, without re-installing rfactor.

    Ive hosted a game and all the guys who patched with the 700mb patch having ‘HDV or track config’ mismatch, no matter wut LOD slider they use.

    Thanks for the response!

  11. @afborro,
    I have made several test yesterday and what I can conclude is that if somebody install the full v1.1 then enter a server where the mod has been patched he will get mismatches. The reverse is the same! If you patch your game and enter a server where the full v1.1 is installed you got the problem too BUT…

    …BUT if you patch your game and enter a patched server it works AND if you install the full v1.1 and join a server with full v1.1 installed it works too!

    Strange but it’s the way it is! I don’t think it’s a LOD problem but I can’t assure it since I’m far from being a freak in MOD creation! 😉

    And finally I understand your point of view and apologize for the doubt I installed here! I thought it was the place to inform people!

    Regards,

    Olivier

  12. Sure, no problem Prenrthouse. It may be than that clearly there is perhaps a larger problem with the patch version and various installation routes whic need to be investigated.

    My statement in the FAQ is in regard to what happens when you do a fresh rf intallation, followed by a fresh 1.1 CTDP installation, and on the server side a fresh rF installation with a fresh 1.1 (DSE) server fresh installation.

    In any case poeple should not be patching the 1.0 server version, always install fresh, or if on an existing installation remove the old v1.0 server completely.

    Thanks for the info.

  13. I’d like to post a question here after some discussions taking place in other forums and I would apprectiate if CTDP can give a short statement. You may have seen some people discussing issues with rear instability during cornering (e.g. with default setup). I had the same problem and finally figured out that (at least for me) even only decreasing the front camber from -3.2 (default) to e.g. -2.4 has a huge impact. With the smaller values stability is much better (ignoring potential negative “long-term effects” for the moment). So I’d like to ask if (1) this was to be expected (2) -2.3 FC is still “realistic” (compared to reak F1 cars) and (3) this big effect is – sorry 😉 – a minor bug in the mod. And I’d like to point out that this mod is really great stuff!!!

  14. -2.4 front camber is usually lower than they run in real life. Typically values so low are only seen at Barcelona. But you may get a similar effect (improving balance) by increasing the rear a touch too. Try something like -1.5 rear and -2.8 front.

  15. I think I have found an issue with the (offline) qualifying session in Bahrain (“Race weekend” mode).

    I’m playing CTDP Bahrain 2005 and qualifying for some reason lasts a full hour and the cars get 12 laps each to play with.

    Then I go to play Silverstone, and suddenly I have 20 minutes of qualifying (like Q3 was in 2006) and 0/99 laps to start with (virtually unlimited).

    I have never tampered with those settings on the .plr or other files so I wonder if there is something wrong there…(maybe an issue with the track files themselves and not with the mod).

    Thanks.

  16. Thanks Michael for your hint, but it did not work out for me (tested again on Shanghai). My impression is that FC has much more impact than RC (or other parameters) on the balance when entering corners. In order to get safely through the first series of turns anything higher (more negative) than -2.5 is not working for me (and a few others who have reported similar issues in other forums).

  17. Hey McFritt,

    I use a higher negative camber setting (I think default -3.2 or -3.4 for Shanghai) and it’s working fine, so I think it’s a matter of driving style…unless I’m too slow to notice.

    I have done about 1:37.0 with 11 laps of fuel on ISI Shanghai and I know I can improve to 1:36.0 if I get a good lap in qualifying conditions (driving aid: TC only).

    So it’s either that I’m slow and you’re talking about being much more on the limit there, or that my preference for oversteering setups makes me not notice the camber issue..

  18. Hey McFritt,

    I sent a comment in, or I think I did, anyway, the gist of it was, it might be a driving style issue. I have my camber at default and there is no problem goign through the first series of corners at Shanghai (using only TC)..But I like oversteery cars 🙂

  19. Hi Pavlos. Hm, this is strange because the rear breaks out so fast that there is hardly enough time to react and save it. Anyway, if I try to enter the slowest part of the 1st series of corners at ~100-110 kph I cannot keep the car on track with the default setting. With lower camber values I have not yet encountered severe issues for the T profile (at least on Shanghai circuit).

  20. Sorry Pavlos & CTDP. I could not believe it and tested Shanghai again with the default setup and… to my surprise things turned out to be different now. I am completely puzzled and a bit embarrased. 🙂 I had quite a number of fast laps and no real issue with car stability in any of the corners. My only explanation is that I had always used 97% brake pressure before (taken from my 2005 car setup) and may have downshifted to 2nd gear at too high rev(?). Now I forgot to change brake pressure. I have not yet tested how good I can now drive with default setup on Indianapolis where I first encountered the problems but, anyway, I will not bother anyone with these camber/stability questions anymore. At times when I was playing F1 RS 2 (= many years ago) this would not have happened. 🙁

  21. @Pavlos: maybe you already know by now but times and laps for qualifying can be set in the track gdb file. Some track (like Shanghai) do not have entries for that. With Bahrain, among others, it’s different. However, I guess there will be online mismatches if you alter the gdb files.

  22. To CTDP team,

    Can you please post an update fixing the AUTOSHIFT bug, at least for the Ferrari… It’s really a basic and most annoying bug that should be eliminated in an otherwise top quality mod.
    So, when can we please expect a simple fix to be posted ? .
    THANK YOU in advance. Llucao

  23. To CTDP team,

    Can you please post an update fixing the AUTOSHIFT bug, at least for the Ferrari… It’s really a basic and annoying bug that should be eliminated in an otherwise top quality mod.
    So, when can we please expect a simple fix to be posted ? .
    THANK YOU in advance. Llucao

  24. hi, i have experienced problem when I want to join our server. I got the same mismatch: “.hdv or track config mismatch”. Ive tried to change LOD (all of them) but no change. I tried to reinstall CTDP 06 (again full 1.1) the same mismatch.
    Some of CTDP developers should take deep look at this problem. Pls dont tell me to change car LOD it didnt help anybody.

  25. the usual questions … what mod-version do you use? Is it the same as the server or is the server running the league token? Did you edit anything? do you have the same tracks installed?

  26. thx for reply.
    I use 1.1 full version. The same on the server, no league token. I did not edit anything. Sure, we have the same tracks installed.
    There are no problems in EMG_Hungary. But when we race non-calendar track (like FsOne08 Valencia or A1 Ring v2.0) the mismatches appears. I tried to delete all user profiles and created new one. I have noticed, that mismatch is connected with team. Midland, McLaren, Williams are OK. Ferrari and Renault not.
    So if this is usual question then you should released fix or patch long time ago.
    Some forums say, that installing 1.0+patch does not have such problems (only full 1.1 version). So I think you should check your websites and tell people to install full 1.1!

  27. Possiblity is that the trackconfigbase.ini files are different when specifying the physics for the misc tracks outside the 2006 calender on the client and server version afer full install 1.1 for some teams , hazard a guess. Points noted, but not had the time to investigate that. I’ll have to check what is contained in the installers, but for what it is worth in 1.2, we’ll make sure this wil be fixed.

  28. hello Vil, first sorry by my bad english. I Explain… I´m admin that any comunity and we have the equal problem and this is the solution :), it´s very best, but we have solution the problem. The problem it´s the server edition (70 mb, more or less). How appear the CTDP 1.0, only version player, not server edition, nobody problem. The problems appear with the server edition. When launch the CTDP 1.1 server edition, we up to the server the CTDP 1.1 server edition (-+70mb) and not full version 1 GB. Big error. This is the problem. When you install other track, different track.ini, you have mistmatch with BMW and Ferrari teams.

    We don´t know the problem, we have this problem any months and we almost change the calendar. After the much test, I decide up the full version 4 gb, descomprimed, and this is the end that our problems. It´s all ok.

    I hope understand me.

    Bye.

  29. Hi pollaman,
    finally I have solved the problem. No need to install Full v1.1 on server. I have done a very small fix for this problem. The problem was that DSE version and v1.0+v1.1patched version uses files with different values than v1.1FULL. Ive found out also when and why the mismatch appears.

    Nowadays everything work fine for me.
    So if you are interested, you can contact me on aszester@gmail.com

    Bye mate

  30. Hi,help!
    Virtually all the races i do offline in any car i am waaaay faster than the AI. Went to the monitor screen and viewed the other cars,they seem to be maxed out in 7th gear at 96mph! How can i fix this,
    many thanks in advance

  31. At my friend such problem: a code it creates or is connected, it mismatch today had this FER_F248. HDV or Track Config, but there are others what to do?

  32. I about this version also speak, on it on the Internet it does not turn out to play in any way and only at one at it such and occurs

Leave a Reply to Taylor Cancel reply

Your email address will not be published. Required fields are marked *